3,547 Irish motoring queries answered to date.

On changagoidem.ie there is no such thing as a silly question. No matter how small or complicated an issue seems, we'll help. Our experts will quickly answer your queries in a friendly and jargon-free manner. What are you waiting for? Ask us Anything!

Please remember that we offer advice, not gospel. We cannot be held responsible for recalls, a second hand automobile's history, acts of God, changes in automobile pricing or Government policy. We are here to help and offer independent, impartial and free advice. What you do with it is entirely up to you!

By submitting a question you are agreeing to this statement. Thank you.

Ask Us Anything

Please ask your question in the box below. We will answer it as soon as possible.

Please note that we may edit the text of your question and that, if you provide your name and town, these will appear with your question. No other personal or information will be displayed or made public.

What's wrong with my Ford Mondeo?

Hello.

I hope you can help. My 2006 Ford Mondeo 2.0-litre TDCi Platinum revs very high when ticking over and also lately will totally lose power and engine will cut out while driving.

Filed under fault - Asked by Anne Mahon (Galway) - Mon, 22 Jul 2013 14:30


What's up with my Mondeo's key fob?

I have a 2008 Ford Mondeo Titanium and have two fobs - one locks and unlocks the automobile and engine will start when I press the push button; second fob locks and unlocks the automobile, but engine won't start when I press the push button and screen says doesn't recognise the key. I changed fob battery, but still the same - any idea/solution?

Aidan

Filed under fault - Asked by Aidan Mackey (Blarney) - Sat, 27 Jul 2013 14:33


Why is my Toyota Levin leaking oil?

My 1999 Toyota Levin AE111 appears to be leaking oil. Recently I put in a new gasket. It looks like the oil is coming out the right hand side and collecting on top of the gearbox. I'm at a loss.

Any ideas?

Filed under fault - Asked by Ray Chawke (Cork) - Thu, 11 Apr 2013 23:38


Why is my Volvo S40 losing power?

I have a low engine performance message in my 2008 Volvo S40 1.6 diesel. Why?

Filed under fault - Asked by Kevin Anthony (Enniscorthy) - Fri, 22 Mar 2013 00:21


How to fix my Peugeot's oil leak?

Cost of repair to head? My Peugeot 307 1.4 petrol has an oil leak.

Filed under fault - Asked by Dermot O Mahony (Automobilerigaline) - Mon, 20 Nov 2017 19:18


Is my Ford Focus diesel too cold?

I have a 2009 Ford Focus diesel. The engine malfunction light came on twice today on way to work. It cut out, I lost power steering and the windows would not work either. The automobile is now parked but it is starting up for me now and the warning light has gone off and all seems fine. What could be the problem please? It is a very cold day here too, maybe the automobile was cold?

Many thanks, Lucy

Filed under fault - Asked by Lucy McDonnell (Blanchardstown, Dublin) - Tue, 28 Nov 2017 09:55


What's the noise in my Toyota Previa?

Hi,

My parents have a 1991 Toyota Previa and lately it has been making a lot of metal grinding sounds from the rear. I took it out to test it and for the first few minutes the automobile seems fine. But after a while, and especially on the motorway, the automobile starts making metal grinding sounds.

We took it to a couple of garages and they said it was the rear axle. To fix/replace it, its going to cost around €700 to €1,000 depending on if we want to fix/replace the whole axle. Can the rear axle really be the problem? And does the price range sound right for this problem?

Thank you.

Filed under fault - Asked by Jin Masaki (Fresno) - Tue, 17 Sep 2013 21:50


What's wrong with my 2007 Skoda Octavia?

Hello,

I have a 2007 Skoda Octavia 2007 1.9 TDI that sometimes won't start - the engine will turn over, but won't start. When it does eventually start it runs ok for a while, then it cuts out and won't start any more: fuel pump, pipes, filter and fuses etc, have been checked and all ok. Have a fault code but not sure if related - P1650 data bus powertrain: missing message from instrument cluster ECU.

Thanks

Steve

Filed under fault - Asked by Steve Daly (Cork) - Fri, 15 Nov 2013 17:26


My Honda's air conditioning is noisy!

The air conditioning in my Honda Civic 1.5 Sport makes an infuriating whistling noise. Have there been any similar complaints? Is there a cure?

Thanks in advance

Dave

Filed under fault - Asked by Dave King (Folkestone) - Mon, 11 Sep 2017 06:44


What's wrong with our Peugeot 207?

Hi,

Our Peugeot 207 has a problem that the mechanics can't get right. When engage (D) Drive, it loses power even when you step on the accelerator. However, when you engage (R) Reverse, it has all the power.

What could be the problem?

Filed under fault - Asked by Henry Buwembo (Kampala) - Fri, 07 Jul 2017 16:22


Back to Question list