Quick automobile review finder - select below

3,816 Irish motoring queries answered to date.

On changagoidem.ie there is no such thing as a silly question. No matter how small or complicated an issue seems, we'll help. Our experts will quickly answer your queries in a friendly and jargon-free manner. What are you waiting for? Ask us Anything!

Please remember that we offer advice, not gospel. We cannot be held responsible for recalls, a second hand automobile's history, acts of God, changes in automobile pricing or Government policy. We are here to help and offer independent, impartial and free advice. What you do with it is entirely up to you!

By submitting a question you are agreeing to this statement. Thank you.

Ask Us Anything

Please ask your question in the box below. We will answer it as soon as possible.

Please note that we may edit the text of your question and that, if you provide your name and town, these will appear with your question. No other personal or information will be displayed or made public.

What's the noise in my Toyota Previa?

Hi,

My parents have a 1991 Toyota Previa and lately it has been making a lot of metal grinding sounds from the rear. I took it out to test it and for the first few minutes the automobile seems fine. But after a while, and especially on the motorway, the automobile starts making metal grinding sounds.

We took it to a couple of garages and they said it was the rear axle. To fix/replace it, its going to cost around €700 to €1,000 depending on if we want to fix/replace the whole axle. Can the rear axle really be the problem? And does the price range sound right for this problem?

Thank you.

Filed under fault - Asked by Jin Masaki (Fresno) - Tue, 17 Sep 2013 21:50


What's wrong with my 2007 Skoda Octavia?

Hello,

I have a 2007 Skoda Octavia 2007 1.9 TDI that sometimes won't start - the engine will turn over, but won't start. When it does eventually start it runs ok for a while, then it cuts out and won't start any more: fuel pump, pipes, filter and fuses etc, have been checked and all ok. Have a fault code but not sure if related - P1650 data bus powertrain: missing message from instrument cluster ECU.

Thanks

Steve

Filed under fault - Asked by Steve Daly (Cork) - Fri, 15 Nov 2013 17:26


My Honda's air conditioning is noisy!

The air conditioning in my Honda Civic 1.5 Sport makes an infuriating whistling noise. Have there been any similar complaints? Is there a cure?

Thanks in advance

Dave

Filed under fault - Asked by Dave King (Folkestone) - Mon, 11 Sep 2017 06:44


What's wrong with our Peugeot 207?

Hi,

Our Peugeot 207 has a problem that the mechanics can't get right. When engage (D) Drive, it loses power even when you step on the accelerator. However, when you engage (R) Reverse, it has all the power.

What could be the problem?

Filed under fault - Asked by Henry Buwembo (Kampala) - Fri, 07 Jul 2017 16:22


How do I get into my Merc SL's boot?!

I am unable to open the boot-lid on my 1992 Mercedes Benz 300 SL roadster. I have been opening manually on key but lock appears to be broken as key does not catch and runs almost freely from side to side. Any other way to open boot-lid?

Filed under fault - Asked by Gearoid O'Driscoll (Bandon) - Wed, 31 Jul 2013 14:42


My Astra's timing belt has snapped...

The timing belt has snapped on my 1999 Opel Astra 1.4: just put on a new belt or put the automobile in the bin? Interference or non-interference?

Filed under fault - Asked by Eamon Mcgowran (Limerick) - Sun, 16 Jul 2017 15:45


My Hyundai ix35 is squealing!

There is a squealing sound near the pullies of my 2011 Hyundai ix35; is it my timing chain?

Filed under fault - Asked by Sylvester Taylor (Oudtshoorn) - Mon, 24 Apr 2017 11:05


I drove through a flood in my automobile. Help!

Yesterday there was a lot of rain near my area and I drove through water at about 20km/h up to my headlights. The automobile stopped as water entered the exhaust. I towed it to my place and it's more than six hours since and my automobile hasn't started yet. What should I do?

Filed under fault - Asked by Dhiren Kinkhabwala (Surat) - Sat, 10 Jun 2017 06:12


Should Volkswagen replace my Golf's sensor?

My 2007 Volkswagen Golf has its ESP light display on. My Volkswagen dealer told me that it was the pressure sensor on the ABS would need replacing and could not be fixed. He told me it would cost €1,500, which I think is outrageous! After some research I saw in the UK that Volkswagen is replacing these free or labour only as there is a known fault.

Any advice/help would be appreciated.

Filed under fault - Asked by Patrick Martin (Dublin) - Wed, 08 Jan 2014 13:42


Loads of problems with my Opel Astra...

Hi,

I have a 2006 Opel Astra 1.4 petrol. The management light is on and a mechanic said he thinks it's just an oxygen sensor, but recently my automobile has not been able to blow out hot air. The coolant seems to be gone, but it was only topped up recently and the engine is very hot after I drove it today and it sounded really loud when I turned on my air conditioning. Also, it is slightly vibrating and there is a whistling noise coming from the automobile.

Any help is welcome

Filed under fault - Asked by Amy Taylor (Dublin) - Thu, 09 Jan 2014 23:49


Back to Question list